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~a%¢ Validation of Exported Field Data in
GEOPAK Drainage (Survey to Drainage)
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1.1 Overview

The Export to GEOPAK Drainage tool can be utilized to leverage data collected by field
surveys (i.e., pipes and structures) into a GEOPAK Drainage project. This can be
extremely useful when the current system is changed or augmented with new structures,
which is often the case in today's transportation and site projects.

Note: GEOPAK Drainage is not required to export to Drainage, but is needed to open the
drainage project for subsequent review.

The key to leveraging survey data into drainage is GEOPAK's ability to determine the
feature code within Surveys and its relationship to items within the GEOPAK Drainage
Library. This association between the Survey Manager Database and the Drainage Library
is a Data Dictionary file. This file (not to be confused with the data dictionary files on many
data collectors and GPS equipment) is an ASCII file, which associates each Feature code,
which could be used for drainage applications and the Item within the Drainage Library.
This file can be set up based on the organization's SMD and DLB; therefore, one file can
be utilized throughout the organization.

Survey points are utilized for the structures (referred to as nodes within GEOPAK
Drainage), while survey chains define the pipes (referred to links within GEOPAK
Drainage.)

GEOPAK scans the specified Coordinate Geometry (GPK) file, which contains the field
data, compares each feature name (and size for pipes) to the Data Dictionary file, and then
displays any item for which a match is found. In this way, nodes and pipes are displayed,
while non-drainage items (such as trees and fences) are not utilized. Once the items are
displayed, the user has the option to use only those items for a particular processing. In
this way, any items that are outside the area on interest may be removed from
consideration.

When processed, GEOPAK finds the node with the lowest invert and assumes this is an
outlet. Then it finds all connected pipes and that becomes a network. Then the process is
repeated until all nodes and links are part of a network.

The pipes, links, and networks are stored in the specified Drainage Project File. Using
GEOPAK Drainage, the user can then review, modify or utilize the information within the
design or upgrade of the drainage project.
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1.2 Deliverables from Surveys

The following deliverables should be received from the Survey personnel:

. GPK file
. Survey Design file
. Drainage project (gdf) file

1.3 Reviewing Drainage Project Information

When the Export to Drainage process is completed, review of the drainage project is
prudent. A comparison of the survey data and its subsequent location in the drainage
project is detailed below.

1. Open a blank MicroStation 3D file and attach the 3D Surveys file. Fit so the surveys
data is visible.

2. Open the drainage project supplied by Surveys. By selecting
a.) Applications>Drainage>Drainage.

b.) Then select Project>Open and select the drainage gdf from the drainage pull-down.

Bt DRAINAGE - Untitled - [No Active Network] ==

Project Component Metwork FReports  Lkilties  Tool Boxes

c.) Select Drainage > Network > Edit.

The Dialog below is used to build (Validation) the networks. Each network is built
individually . First select the Network ID (top left of dialog) then Select the Build Network
icon (bottom left of dialog).

B Network Configuration - [DWR5300] = || =) ER
Network ID: 4 [DW65300 ~| O B | Apply
Details
Description: Outlet Node: [DW65300 | o

Validati Computati
aligation ampRLEtans | Lock Sizes | | Unlock Sizes |

}i ‘:;I?ﬁ P“Ifﬁ | Lock Bevations | |L|n|u:.u:|-: Eleuatinns|
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When the Network is built within Drainage, the number of Nodes and Links in the
Information dialog matches the number of Nodes and Links in the Export dialog. Now build
the remainder of the networks.

Information

. Metwork DWE5300 Successfully Built
1 Total Node in Wetwork = 3
Total Links in Network = 2

3. Now select Utilities>Navigator. The dialog below displays the Drainage Navigator in the
Link mode.

Bt Navigator = | @ &
View Tools

wx ow sy
D Description -
CCMP3 BC: 0 EC: O &1
CCMP5 BC: 0 EC: 1 3
CCMP7 BC: 0 EC: O T W
CCMPB BC: 0 EC: O
CCMPS BC: 0 EC: O i
CRCP3 BC: 0 EC: O
CRCP4 BC: 0 EC: O i 11

[] Highlight [] Window Certer  [] Queny

Next, review an individual entry for a Link (in this example (CCMP3) by a double-click on
the link you want to review from the Navigator.

Note the Shape, Material, Size, Manning's n, and Override Library Pay item are
populated from the Exporting process.

B | ink Configuration Definition o |l = &
Link 1D: 4 [[I,I‘u'IPB v] > [] Window Center A 4 ,—}'
[] Highlight

Details

Description: | BC: 0 EC: 0

[?;1;:;;“ From MNode: &t To Node: Tt
Conditions Length: (66.2848 [[] Use MS Elemert [l
Constraints Corfiguration
Computation Shape: Material:
Type [T] Design Size  Size: 12in
@ Fipe [7] Design Bamels  Mumber of Bamels: Roughness: | 0.011
(© Ditch Ovenide Library Paytem: | CEXDRNCMP
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The Length in the drainage dialog can be verified by selecting DESCRIBE SURVEY
CHAIN CCMP10 in COGO as shown below.

B Coordinate Geometry Job: 001 Operator: jm o || =
File Edt Element View Tools

I:R. % k _:_::E A /ﬁl’é f Ir% l(@-lE fi 14224 f_j Ij' Ttzzd " EI % p
[7] Redefine (Disable Visualization ¥ )| OFF (Feature) [ [ Browse | (8812 ) (g799.12" -..

COGO Key4n: | DESCRIBE SURVEY CHAIN CCMP3

| &2

; mﬂ

< 1 DESCRIBE SURVEY CHAIN CCHE3

SBurvey chain CCMP2 contains:
DWe5041 DWe5051

Beginning surwvey chain CCMP3 description.

Data Set: DRATH
Zone: 1
Lttribute: NOTINCLUDED
Feature: CCHME3
Description:
Station: a+0a .00
Point:DW&5041 H 543, 337.68 ¥ 173,471.32 Z 445_3090 g
Dataset:DRAIN Zone:l Geometry:POINT Attribute:NOTINCLULDED
Y CCHE3

- MNDT FL ENT

Course from DW&5041 to DWESO051  117° 2Z3' 10.13" :.‘list
Slope Dist €6.29% Elev Diff 0.74 Grade 0.01

Point:DW&5051 ¥ 543, 3%96.54 ¥ 173,440.83 Z
Dataset:DRATN Zone:l Geometry:POINT Lttribute:NOTINCLUDED
Y CCHMP3
LY MNDT FL ENT

Ending survey chain CCHMP3 description.

The elevations of the links can also be verified by reviewing the two points in COGO and
the Link dialog in the Conditions option. The sample COGO dialog below has the two
shots for CCMP10. The dialog below depicts the same pipe, the Link Configuration Dialog.
Note the two-invert elevations match the two elevations in the COGO dialog above.
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Bt | ink Configuration Conditions | = | = || 22
.
Link ID: 4 [CCMP3 -] » :’i"g”hcl';”‘:dcemer VAR A4
Detailz
! Profile Conditions
DD;TID;S From MNode Slope To Node
initicn i _
Conditions Min Cover: 1446305 1.118 1445 568
Constraints Soffit: 447 31} 1.118 445 BRD
Computation Irvert: 1446309 [& 1445568 [
Type Max Depth:  1386.305 1.118 1385568
@ Pipe
{7 Ditch

1.4 Drawing Drainage Project Information

1. If not done in 1.3.1, open a blank MicroStation 3D file and attach the 3D Surveys
file. Fit so the surveys data is visible.

2. Open the drainage project supplied by Surveys.
3. Select Drainage > Project > Preferences > Project Components.

Verify that the Drainage Library Files (DLB) is
S:\MndotV8Stds\DOT_GEOPAK\dIb\hyde.dlb

Verify that the GPK Job Number is correct and the the Road Preferences are set
correctly

Verify that the Drainage Cell Files is
S:\MndotV8Stds\DOT_MICRO\cell\hydro.cel

Verify that the GEOPAK DDB is
S:\MndotV8Stds\DOT_GEOPAK\db\english.ddb

4.  Select Drainage > Utilities > Navigator and review the networks.
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5.  To draw the pipes, highlight all links in the Navigator, and select Tools > Update
Pay Items. This will draw the flow arrows (using the linestyle SEW(R))

H Mavigator

View | Tools

X |Update Graphics -

= | |pdate Pay tems | f % I Y
D Description -
iCCMP3 BC: O BEC: D

CCMP5 BC: 0 BC: 1

CCMP7 BC: 0 EC: O

CCMP8 BC: 0 EC: O

CCMPS BC: 0 EC: O

CRCFP3 BC: 0 EC: O

CRCP4 BC: 0 EC: O

m

X Lo

[] Highlight  [] Window Center

[] Query

[
pad

t=

6. To draw the structures, highlight all nodes in the Navigator, and select Tools >

Update Pay Items.

[m] »

X Lo

Bt | avigator
View | Tools
. | |Update Graphics |@/ % .,. Y
X |pdate Pay tems
1] Description
iDWeR000 CAFR
DWeR010 CAFR
DWeR020 CAFR
DWWeR030 CAFR
DVWeR040 CEND
DVWeR050 CEND
DWeR070 CEOSA
[] Highlight  [] Window Center Cluery

[
pad
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1.5 Set to Project Chain and Offset

1. Select the GPK file with the chain you are assigning has been set in the
Preferences.
2. Select Project>Preferences>Project Components

/) DRAINAGE - 6916.gdf - [No Active Network]

Project | Component Metwork Reports Utilities Tool Boxes
Mew. ..
Open...
Save
Save As...

Preferences
Drainage Library

Import
Export

Exit

. ASelfTraintmohr 1jont Survey|6916.gdf
pw:\SelfTrainimohr 1jon\Survey\99.qdf

7! Preferences - Project Components

File
Dptions : Drainage Library File (DLE]: | :py\g; \CADDStandards\M nQVDTS!apd: Q
| Units { 2l |
Fioect Conporents bl ERE
|Rainfall Parameters Drainage Cell Library: | pw:A\CADDStandards\MnDOTStand | Q
Land Use Options B : Q
| Frequency Options Criteria Ditectory: S ————— -
Intensity Option DDB: | pwACADDStandards\MnDOT Stand | @
|Junction Losses : : i
Inlet Options “Water and Sewer Project: Q
\Node Options Superelevation Shapes File: Q
|Link Options - :
| Prafile Options [[] Site Project:
Plan Symbology Original Ground
Updates [TINFile  ~| Q
Save Options — - :
Design Surface
i ) [TINFile | Q
'

2. Open the Drainage Navigator (Drainage > Utilities > Navigator).

3. Set the Active Component Type to Node. Select all the Nodes that you wish to
assign the alignment to. Load Global Editor (View/Global Editor).
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"1} Navigator
f\'a'ieljv | Tools
Mavigator alx
Global Editor @ ‘&’ ﬂ ‘/ % I Y
1D Description A
i DWES000 CAPR 1= || a)
DwES010 CAaPR
DwES020 CAPR »../
DwES030 CaPR £
DwES040 CEND
DWwWES050 CEND
DWESO70 CEDSA v i
[] Highlight [] Window Center Gue

4. Choose variable to edit: Node - Reference Chain. Turn on button Overwrite Text, and
type in Chain name. Left-click Apply Edit No Confirm button (at this point, if you look at
one of the nodes, the alignment should have been assigned, but the station won't have
been updated yet).

! Global Editor

View Tools
‘ xJ{ % | @ W Q / % -’ Y Current Value:
| ID  Description A Variable to Edit
Diw/E5000 CAPH | |Node-ID » @ Owerwrite Text:
DWwWES010 CAPR Node - Description [T
DAWES020 CAPR Node - Refererice Chain : New Text | I¥K |
Dw/E5030 CAPR Node - Reference PGL ) Find and Replace:
Diw/65040 CEND Node - Reference TIN = FrdTest [ |
Di/65050 CEND Node - Elevation .
Dw/B5070 CEDSA ¥ || |Node - Reference Elevation v et I ]
[ Highlight [ ] Window Center Jue [ Apply Edit With Confirm | | Apply Edit No Confirm |

5. Back in Navigator, select all of the nodes (or all for which alignment assigned).
6. Tools/Update Graphics - now station/offset should be updated for each of these nodes.

7. To Verify the chain, station, and offset Select Drainage > Component > Node >
Location. For each of the nodes you changed.
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1.6 Create Existing Tabulation Sheet

1. Select MnDOTMenu > VBA > Drainage > Drainage Tabulation from MicroStation
Tool Bar.
2. Select the Drainage Database (gdf) you want to tabulate.

Ic:'1projectwise‘l,pw_worldng'l,mohrljon'gt Q

Sheet:l vl Nl ‘l }l (4
Table Type: [TETETDEEE <]

Profile Table

i~ 1+ Erosion Control Table

: Casting Assembly Table
Profile Table (Metro
- Inplace Drainage Table.

Drainage Tabulations

Drainage Database:

3. Select Inplace Drainage Table for Table Type

Drainage Tabulations

Drainage Database:

[c:'l,projectwise'l,pw_working'l,mohrljon'gt Q

Sheet:l v]A NI ‘l }lq

Table Type: IIana-:e Drainage Table L’

Save Table to File

Note: This vba creates a table for all of the nodes and links within the gdf.
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4. Save the Microsoft Excel file.

General ‘

Folder [see ]
L | (e

Document

Mame: isZ?é&_test_hyd.xlsx

Description: EsZ?Zé_test_Fyd

File Name: | s2726_test_hyd.xlsx

Format: | XLSX Format,..

Application: Department:

ook
Microsoft Excel vJ \.<none> v |

5. Wait until the Table Complete dialog displays, select OK

MicroStation

Table Complete

QK

6. Open the Excel file you just created.

INPLACE DRAINAGE TABULATION

. STRUCTURE LOCATION DRAINAGE STRUCTURES PIPE SEWER
g E CASTING EOTTOM g E s & E
©w A = I - ~

g % ALLEN STATION OFFSET STATION OFFSET E 5 E E E ;Cn' E E £A8TING E E :‘ E E : g = e

=4 a = Gwe - O &= ELEV pm ERAs S CPP PVC

2 [~ du =) w B
DH61810 | DHE1820 114+05.61] 24 CB 4.5 Existing Grate 847.28 | 842.78 843.29 75
DHEL1S810 | DHELSED 114+05. 61 24 CB 4.6 Existing Grate £47.28 | 84Z2.68 84Z2.31 51
DHE1060 | DHELODSO 135+24.19 -2l CB 2.4 Existing Grate 836.22 | 833.82 831.69 44
DHE1070 | DHE1OS0O 134+31.85 -Z5 CB 2.5 Existing Grate 837.27 | 834.77 834.34 Sl
DHE0SE0 | DHEOS70 145+44 .89 34 MH 4.8 Existing Manhole 240.69 | 835.89 836.63 z0
DHE0970 | DHESSZ0 145+62.22 23 MH 3.5 Existing Manhole 840.33 | 836.83 836.87 11
DHEO330 | DHEO340 169+58. 79 =2zl CB 2.7 Existing Grate 835.15 832.4 831.85 16
DHE1Z60 | DHELZ70 174+28. 95| -2l CB 2.9 Existing Grate 833.54 | 830.64 829.08 45
DHE1330 | DHE132Z0 174429.25 21 CB 2.8 Existing Grate 833.8 831 829.18 45

= = - = = = -

~

There are empty columns you should hide.
8. Modify as needed and import tab into a dgn using Axiom Office Importer.
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